Digital Identity Lab of Canada - we are investigating a possible issue with our emails

Major incident Lab Infrastructure | Infrastructure du laboratoire
2020-10-19 08:43 EDT · 3 minutes, 59 seconds

Updates

Resolved

We have taken steps to resolve the issue with email notifications. If you are experiencing any other problem, please contact us at support@digidlab.ca.

October 19, 2020 · 08:47 EDT
Investigating

We are currently investigating reports of a potential issue with email notifications. We’ll post an update as soon as we know more.

October 19, 2020 · 08:45 EDT

← Back